Fill Probe

If you have any problems with your plumbed Dream machine where it worked fine out of the box but sometime later something happened during the 2-Year warranty period, ask about it here. Once fixed please keep us posted on what had to be done to resolve the problem.
Post Reply
jemery

Fill Probe

Post by jemery »

I am not sure this is exactly a failure, but I am wondering what other folks might think. Basically after about 3 months I had a few incidents where on starting the Dream the steam pump started running and would not stop, overflowing water all over the place. After a few emails and calls with Chris Coffee and subsequently taking the machine apart and removing the fill probe, basically the fill probe has scale on it and needs to be cleaned. I used some fine sandpaper and it worked perfectly after that. My concern is mainly - is this really something I should have to do every 3 months? We've had other espresso machines for years and never had a similar issue of any sort.

One more thing - here is a pic of my water hardness test. We do not have a softener, just the filter from CC installed. Would it be recommended to add a water softener or anything else to be done to prevent this from ever happening again?
IMG_2114.JPG
IMG_2114.JPG (181.48 KiB) Viewed 6109 times
Thanks,
User avatar
chas
Vivaldi Dreamer
Posts: 2968
Joined: Wed Jun 02, 2004 11:52 pm
Location: Central Maryland
Contact:

Re: Fill Probe

Post by chas »

Based on the test strips you're hardness looks fine. HOWEVER, using those same strips my hardness also looks fine. Still I wasn't sure I trusted the strips so I recently bought a liquid based tester like those used for aquariums or pools. Using that liquid tester, instead of 3 grains like I thought I had using the test strips, I am seeing 7 grains AFTER softening through a new cartridge and more like 14 grains on the input side of the cartridge.
Chas
LM GS/3 & LaSpaziale Dream v 1.23 (US 120V)
Mazzer Kony E, Customized Rocky
Hottop P/B
jemery

Re: Fill Probe

Post by jemery »

Interesting - I'll have to check that out. We are on well water so it doesn't have chlorine either - not sure what that means - except wondering if we have the same or different filtering requirements. Is the test you are checking for specifically water hardness or some other minerals or something in the water?

Thanks,
goodboyr
God Shot
Posts: 248
Joined: Thu Jan 10, 2013 10:05 pm
Location: Canada

Re: Fill Probe

Post by goodboyr »

My experience is the same as Chas. My strips looked like yours, but when I used the liquid aquarium test kit I had 17 grains input instead. I added a bestmax combo filter/ix unit and that brought it down to 3 grains on bypass 1 on the filter.
Bob
La Spaziale Dream and Baratza Sette 270W
Post Reply

Return to “Dream In Warranty Issues”