Steam Boiler not filling

If you have any problems with your plumbed Dream machine where it worked fine out of the box but sometime later something happened during the 2-Year warranty period, ask about it here. Once fixed please keep us posted on what had to be done to resolve the problem.
Post Reply
Jammer1
Americano
Posts: 6
Joined: Sun Nov 06, 2016 1:20 pm
Location: Akron Ohio

Steam Boiler not filling

Post by Jammer1 » Sun Nov 06, 2016 2:18 pm

I just set up my Dream machine. I turned the machine on and then pressed the blue button to turn the steam boiler on. The LED readout then shows the coffee cup on the screen and below it it scrolls "TBOILER" and the temperature. The temperature does not change and the pump never kicks on to pump water into the boiler. I can press the hot water button and nothing comes out. What am I missing? Any ideas as to why the steam boiler won't fill?? Thanks!

User avatar
chas
Vivaldi Dreamer
Posts: 2565
Joined: Wed Jun 02, 2004 11:52 pm
Location: Central Maryland
Contact:

Re: Steam Boiler not filling

Post by chas » Sun Nov 06, 2016 3:29 pm

No luck on the Chris Coffee FB page, eh? At least I assume that was your post I saw there yesterday.

When you first power on the Dream, the pump should come on and the solenoid that allows the flow of water into the steam boiler should click on. When the pump and the solenoid come on simultaneously (proper operation) you may not be able to hear the solenoid over the pump. However, since the pump is not coming on in your case, do you hear the solenoid click on?

If neither is happening it sounds like the water level sensor may have failed in a way that makes the controller board think it is shorted to ground. Alternately, the water level sensor may have gotten bent inside the machine so that it is either touching the boiler or the heater element. At least this issue would be fixable without replacing the sensor.

Checking this out requires that you remove the covers, locate the water level sensor, pull the sensor out of the boiler and give it an inspection. As a quicker test you can disconnect the wire from the sensor and turn on the machine briefly. If the machine starts filling then the problem is definitely with the sensor. Don't leave the machine on like this for too long if the pump does star running to fill the steam boiler since it will not shut off and the boiler will overflow after 15-20 seconds or so. Also, until this problem is fixed don't enable the steam boiler for too long or the heater element may fry.

BTW: After bench testing at Chris Coffee, they drain the boilers and remove the solenoids and blow the remaining water out with compressed air. Occasionally, folks have gotten machines delivered where the tech forgot to reconnect the power leads to the solenoids. So if you remove the covers inspect the solenoids for that issue as well.
2016-11-06_15-27-29.png
(471.79 KiB) Downloaded 2790 times
Chas
LM GS/3 & LaSpaziale Dream v 1.19 (US 120V)
Mazzer Kony E, Customized Rocky
Hottop P/B

Jammer1
Americano
Posts: 6
Joined: Sun Nov 06, 2016 1:20 pm
Location: Akron Ohio

Re: Steam Boiler not filling

Post by Jammer1 » Sun Nov 06, 2016 5:55 pm

Ha you are following me. Frustrating to get a new machine and it doesn't work!

When I turn the boiler on- 8 don't hear any clicks. To pull the water level sensor- you just pull it out correct? I'll pull it and see if anything happens...

The power connections appear to be all made.

Thanks for your help!

User avatar
chas
Vivaldi Dreamer
Posts: 2565
Joined: Wed Jun 02, 2004 11:52 pm
Location: Central Maryland
Contact:

Re: Steam Boiler not filling

Post by chas » Sun Nov 06, 2016 6:01 pm

Just loosen the top nut, leaving the bottom one alone. The top nut cinches a nylon sleeve against the sides of the sensor holding it in place. With that nut loosened a bit, you should be able to pull the water level sensor up and out.
Chas
LM GS/3 & LaSpaziale Dream v 1.19 (US 120V)
Mazzer Kony E, Customized Rocky
Hottop P/B

User avatar
chas
Vivaldi Dreamer
Posts: 2565
Joined: Wed Jun 02, 2004 11:52 pm
Location: Central Maryland
Contact:

Re: Steam Boiler not filling

Post by chas » Sun Nov 06, 2016 6:10 pm

BTW: The water level sensor on the Dreams is a bit different than what is shown in the photo I attached. On the ones I have seen, the wire connects via a screw thingee rather than it being a slide on connector as shown in the original photo. Functionally, it's the same however.
dream.png
(347.33 KiB) Downloaded 2786 times
Chas
LM GS/3 & LaSpaziale Dream v 1.19 (US 120V)
Mazzer Kony E, Customized Rocky
Hottop P/B

Jammer1
Americano
Posts: 6
Joined: Sun Nov 06, 2016 1:20 pm
Location: Akron Ohio

Re: Steam Boiler not filling

Post by Jammer1 » Sun Nov 06, 2016 6:12 pm

Bingo! Disconnected the probe wire and it filled. So do I need a new probe or...?

User avatar
chas
Vivaldi Dreamer
Posts: 2565
Joined: Wed Jun 02, 2004 11:52 pm
Location: Central Maryland
Contact:

Re: Steam Boiler not filling

Post by chas » Sun Nov 06, 2016 6:26 pm

Good news. Worst case Chris Coffee can overnight you a replacement part tomorrow and you'll be up and running on Tuesday. But first let's see if your current sensor is really bad. The sensor probe cannot touch metal. There can only be a current path through the water to the grounded boiler shell for it to work. Other than the wire it's connected to, it can't touch anything but the insulated white nylon sleeve, and the water in the boiler.

1) Is it possible that the nylon sleeve that the probe goes into the boiler through has slipped out of place or has developed a hole? If this is the case then a new sleeve may be what you need and it is probably not the sensor at all. The sensor is just a metal rod with a single wire connected to it so I am guessing it is OK.

2) How long is the sensor rod? I think they are usually only 2-3" long.

3) Did it appear bent at all or does it look like it would correctly go straight down into the boiler.

It could be any of these things. However, that nylon sleeve is the most likely culprit, especially if the other two items above appear OK. You may want to remove that sleeve, inspect it, then carefully replace it if it is not torn or otherwise showing any damage. When replacing it be sure you see a bit of the sleeve sticking above the nut as shown in the photo in my last post. If the sleeve slipped down so that the sensor is directly touching the nut, that would cause this issue. These machines undergo a lot of vibration in the back of the delivery truck enroute and stranger things have happened.
Chas
LM GS/3 & LaSpaziale Dream v 1.19 (US 120V)
Mazzer Kony E, Customized Rocky
Hottop P/B

Jammer1
Americano
Posts: 6
Joined: Sun Nov 06, 2016 1:20 pm
Location: Akron Ohio

Re: Steam Boiler not filling

Post by Jammer1 » Sun Nov 06, 2016 6:44 pm

The rod is straight and looks good other than the fact that the tip is sharp on the edges from being cut. Maybe it cut the nylon sleeve due to the sharp tip. I'll call ccs tomorrow...

Thanks again for your help- it is truly appreciated.

Joe

User avatar
chas
Vivaldi Dreamer
Posts: 2565
Joined: Wed Jun 02, 2004 11:52 pm
Location: Central Maryland
Contact:

Re: Steam Boiler not filling

Post by chas » Mon Nov 07, 2016 9:14 pm

Is CCS overnighting you a new part?
Chas
LM GS/3 & LaSpaziale Dream v 1.19 (US 120V)
Mazzer Kony E, Customized Rocky
Hottop P/B

Jammer1
Americano
Posts: 6
Joined: Sun Nov 06, 2016 1:20 pm
Location: Akron Ohio

Re: Steam Boiler not filling

Post by Jammer1 » Wed Nov 09, 2016 12:14 pm

Well I called Monday morning and I am supposed to get it this afternoon...

Jammer1
Americano
Posts: 6
Joined: Sun Nov 06, 2016 1:20 pm
Location: Akron Ohio

Re: Steam Boiler not filling

Post by Jammer1 » Thu Nov 10, 2016 7:42 am

Got the new probe and fitting...works now. Thanks for your help!

User avatar
chas
Vivaldi Dreamer
Posts: 2565
Joined: Wed Jun 02, 2004 11:52 pm
Location: Central Maryland
Contact:

Re: Steam Boiler not filling

Post by chas » Thu Nov 10, 2016 9:27 am

Great. Glad to hear it. When taking off the old one, did you see signs of anything that might have caused the failure?

That part rarely fails. The most likely issue with that part happens after a year or more of operation - unless the design has been improved. The nylon insulator can shrink just slightly from the heat. When that happens the boiler pressure can push up the water level probe enough so that the boiler starts getting overfilled.

Repair is just a matter of pushing the probe back down with your fingers and retightening the top nut.
Chas
LM GS/3 & LaSpaziale Dream v 1.19 (US 120V)
Mazzer Kony E, Customized Rocky
Hottop P/B

Post Reply

Return to “Dream In Warranty Issues”