Dream Issues - The saga

General questions, comments, and discussions about the Plumbed Dream machine. New owners post your impressions of your Dream - likes, dislikes, and any other comments.
Post Reply
hhatzis
Freeze Dried
Posts: 2
Joined: Sat Mar 06, 2021 10:19 am
Location: Rhode Island

Dream Issues - The saga

Post by hhatzis »

Hi Everyone,

I am a long time owner of the La Spaziale Vivaldi. Bought it new in 2004 and it finally became quite problematic 6 months ago. I finally decided to purchase a new machine and looked at what La Spaziale offered since the original lasted for 16 years.

I purchased a Dream and it worked well for 3 weeks. One day the boiler would not heat and it kept throwing a "failed boiler temperature alarm". I called the dealer and they replaced it with a new Dream. They wanted to repair the first one but we told them that a machine that failed after three weeks gave us no confidence for a long lasting future.

We unboxed the new machine which much to our dismay came with a scratched chrome front panel. They evidently packed the braided hose in the tray and the gentle UPS people must have given it a rough ride which caused the panel to get scratch. No biggie as the dealer said they would replace it.

We connected the machine to the water filter and that is when the problems began...right out of the box, we were getting low pump pressure and flow meter failures. We couldn't get water dispensed out of either the coffee group or boiler. The 2A fuse on the right hand side bottom keeps popping. If we replace the fuse, the pump will dispense water but only for 20 seconds and then the fuse blows again. We tried adjusting the pump pressure as stated in the manual but the display value when the pump is running stays put at about 4 bars regardless of where the outer screw is placed.

The machine is hooked up to the same electrical outlet and water supply as the Vivaldi. The water flow is 2 liters in 30 seconds. The wall voltage is a steady 117 VAC. The dealer basically said to return the machine and they will refund our money. This is really not the outcome I wanted. However, dealing with rude technicians is not something I want either. Not sure whether to take the money and run or have them repair this machine. A two for two failure rate is not filling me with optimism.

Any opinion would be welcome. Shipping it back and forth is a pain.
User avatar
chas
Vivaldi Dreamer
Posts: 2963
Joined: Wed Jun 02, 2004 11:52 pm
Location: Central Maryland
Contact:

Re: Dream Issues - The saga

Post by chas »

If I were you, I'd definitely ship it back and get something else. BTW: Is that fuse really 2A? It should be 20A, but that's not the only thing going on.
Chas
LM GS/3 & LaSpaziale Dream v 1.23 (US 120V)
Mazzer Kony E, Customized Rocky
Hottop P/B
hhatzis
Freeze Dried
Posts: 2
Joined: Sat Mar 06, 2021 10:19 am
Location: Rhode Island

Re: Dream Issues - The saga

Post by hhatzis »

There are two fuses..

A 20 amp that is fine and a 2A for the pump
User avatar
chas
Vivaldi Dreamer
Posts: 2963
Joined: Wed Jun 02, 2004 11:52 pm
Location: Central Maryland
Contact:

Re: Dream Issues - The saga

Post by chas »

Interesting. I've either never noticed the 2A fuse on my Dream or else they added it after mine was manufactured. Given the purpose of the 2A fuse, it sounds like the motor has either gone bad or else the pump has mechanical issues that are loading down the motor.
Chas
LM GS/3 & LaSpaziale Dream v 1.23 (US 120V)
Mazzer Kony E, Customized Rocky
Hottop P/B
Post Reply

Return to “Dream General Q&A”